ISSUE: The operation couldn't be performed because object 'firstname.lastname@domain.com' couldn't be found on

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Overview

During the move mailbox step, the error below occurs.  

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Cause

This error indicates that the user on-prem user account is not properly Azure AD Syn'd and therefore cannot be found in Azure AD.

Solution

To confirm this in Azure AD, connect to MSOnline or Azure AD.

Checking with MSOnline:

  1. Open an administrative PowerShell session
  2. Type and run - connect-msolservice
  3. Login in with your O365 admin account
  4. Type and run - get-msoluser -userprincipalname <UPN>
  5. If there is no result you have confirmed the user has not been AD Sync'd

Checking with Azure AD:

  1. Open an administrative PowerShell session
  2. Type and run - connect-azuread
  3. Login in with your O365 admin account
  4. Type and run - get-msoluser -userprincipalname <UPN>
  5. If there is no result you have confirmed the user has not been AD Sync'd

In either case, you will need to ensure the user is Azure AD sync'd.  Once that has occurred,  the failed task will need to be restarted by clicking the Restart button.

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