ISSUE: Remove License step completes with error

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Overview

The symptom of this issue is when using the Assign License step and there are no user EV archives being migrated when reviewing the Archive Progress page in the portal.  Additionally, on the Onboarding Progress page, there is a list of users that show the following status:

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If the Assign License step is configured to use 20 licenses, for example, there should be a maximum of 20 EV migrations in progress.  In this case, there was only 1.  

Querying the AssignLicenseBuffer table shows a list of 20 user mappings.  If we look for them on the Finished Workflows page, then review the Details for this user, we find the Remove License step shows as completed, but there is an error. 

Unable to assign this license because it is invalid or license has been deleted

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The error is a bit counter-intuitive as it states "unable to assign" when this step is actually removing the license.  Nevertheless, there is still an issue.  

Cause

This was caused by the license being removed from the user(s) before our Remove License step was able to run (hence the last part of the error "license has been deleted").  The customer confirmed this by reviewing the audit logs.  

Solution

In order for the migrations to continue, the AssignLicenseBuffer table must be cleared out.  This will then allow licenses to then be assigned so the process can continue. 


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