ISSUE: Mailbox Move step fails with error 'StoragePermanentException'

Last modified:


Overview

During the Mailbox Move, the error below will appear in the admin portal.

10 % complete. Status is Failed and Status Detail is FailedMAPI (BadItemsEncountered: 0). Failure message is StoragePermanentException

Image 238

The above error is unclear on the exact issue. The actual error is in the Exchange backend logs as seen below.

Move mbx statistics for yourname@mycompany.com: Percent complete [10] | Status [Failed] | Status detail [FailedMAPI] | Message [Error: Could not create folder '9340'. --> MapiExceptionFolderHierarchyChildrenCountQuotaExceeded: Unable to create folder. (hr=0x80004005, ec=1253)

Cause

The error indicates that the mailbox contains more than 10,000 folders which is the maximum for an O365 mailbox.

Solution

The user will need to clean up the folder list in the mailbox before the migration can proceed.


Is this article helpful for you?