ISSUE: Max send/receive size for mailbox is set to 0
Last modified:
Overview
Configure message size limit may fail with the following error:
"Max send/receive size for mailbox is set to 0"
Cause
When the store message size limit task ran PowerShell command to find the current message size limitation it got 0 as a result for MaxSend and MaxReceive limit. Than this value is stored in the DB
Solution
This can only be fixed manually in the database:
1. Go to tenant database
2. Run following query against dbo.Mailboxes table:
update Mailboxes set MaxReceiveSize=36,MaxSendSize=36 where id in (select ExchangeMailboxId from MailArchiveMigrationMappings where Id in (select MigrationProcessId from ProcessSteps where StepErrorText like 'Max send/receive size for mailbox is set to 0%'))
NOTE: MaxReceiveSize=36,MaxSendSize=36 is value in MB and can be adjust per needs.
3. After you ran the query, restart the failed step in Workflow Progress page