ISSUE: Enterprise Vault is temporarily unable to process the request
Last modified:
Overview
Cloudficient EVComplete EV module may log following error in the logs:
EXCEPTION: System.Runtime.InteropServices.COMException (0x80040302): Enterprise Vault is temporarily unable to process the request. The server is busy, or has insufficient resources, or is only able to read data due to ongoing backups. Wait a while and then try again.
at KVS.EnterpriseVault.Interop.IItem.Get(Int32 DetailLevel)
at cloudficient.EVComplete.Module.EnterpriseVault.EVApi.MailArchive.GetItem(IItem item) in E:\_w\o\1\20\s\cloudficient.EVComplete.Module.EnterpriseVault\EVApi\MailArchive.cs:line 219
at cloudficient.EVComplete.Module.EnterpriseVault.EVApi.MailArchive.ExtractEVItem(IContentManagementAPI evAPI, String archiveId, Guid idTransaction, String contentSectionId, Boolean useTemporaryFile) in E:\_w\o\1\20\s\cloudficient.EVComplete.Module.EnterpriseVault\EVApi\MailArchive.cs:line 190
at cloudficient.EVComplete.Module.EnterpriseVault.EVApi.MailArchive.ExtractEVItem(IContentManagementAPI evAPI, String archiveId, Guid idTransaction, String contentSectionId) in E:\_w\o\1\20\s\cloudficient.EVComplete.Module.EnterpriseVault\EVApi\MailArchive.cs:line 154
at cloudficient.EVComplete.Module.EnterpriseVault.EVApi.MailArchive.ExtractEVItemInternal(IContentManagementAPI evAPI, String archiveId, Guid idTransaction) in E:\_w\o\1\20\s\cloudficient.EVComplete.Module.EnterpriseVault\EVApi\MailArchive.cs:line 141
at cloudficient.EVComplete.Module.EnterpriseVault.EVApi.MailArchive.ExtractEVItem(String evHost, String archiveId, Guid idTransaction) in E:\_w\o\1\20\s\cloudficient.EVComplete.Module.EnterpriseVault\EVApi\MailArchive.cs:line 94
Cause
The error above could be related to:
– Hanging Storage service– Not enough resources (RAM, CPU)
– Not enough free space on disks
– EV Storage Queue disc volume has breached the threshold of 10%(Default) free disc space
– Ongoing Backup
– EV Vault Store partition is set to closed
– EV archive status set to Unavailable
Solution
It is recommended to review the Enterprise Vault environment to check for possible cause from above and determine the issue.