HOW TO: Deal with BadItemLimits
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Overview
During the Move mailbox step, you may receive a Failure type of "BadItemLimitExceededPermanentException", which will leave the move request in failed status.
Cause
The BaditemLimit configuration has been exceeded.
Solution
When dealing with BadItemlimits there are two options:
A: Increase the BadItemLimit and resume mailbox migration:
1. Connect to Exchange Online via powershell
Connect-ExchangeOnline
2. Check the badItemlimit value from the move request statistics
Get-MoveRequestStatistics -Identity "user@contoso.com | Format-list"
3. Increase the bad item limit above the current value that is shown in the previous step
“Set-MoveRequest -Identity "user@contoso.com" -BadItemLimit 100”
4. Resume move request
“Resume-MoveRequest -Identity "user@contoso.com"
B: If there is a widespread issue across Exchange, repairing the Exchange Database can be considered although not guaranteed to fix the bad messages.