ISSUE: 'Too many folders found' error during migration
Last modified:
Overview
During the ingestion to an O365 mailbox, some items fail with the error below:
Too many folders found. This should not be possible. [Root Folder Id: MsgFolderRoot] Folder Name to search: [ArchiveData]. Found folders: [ArchiveData (AAMkADc4YmU0MzYzLTZkNzQtNGY4Yy1iYTY2LTBjMGUxZjIwNDlkNAAuAAAAAACJYmsuPrXgSIsUxt+mFa/4AQDmVhz1kD/nR7OecU9iR5SVAAF1XAcMAAA=)| ArchiveData (AAMkADc4YmU0MzYzLTZkNzQtNGY4Yy1iYTY2LTBjMGUxZjIwNDlkNAAuAAAAAACJYmsuPrXgSIsUxt+mFa/4AQDmVhz1kD/nR7OecU9iR5SVAAEjcmk+AAA=)]
Cause
EVComplete migrates items to the folder in the mailbox based on the folder path in the EV database which is where the item was archived from.
This issue occurs when there are two folders with the same name under one root folder.
Solution
Below are options to resolve this issue within the user's mailbox:
1. Merge the two folders into one
2. Rename one of the folders
3. Delete one of the folders
Once this has been resolved, the exchange module needs to be restarted and the step then needs to be set to 'retry failed ingestion'.