ISSUE: Add User to AD Group step fails with error 'Execute_AddUserToADGroup Phase 1'
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Overview
During the Add User to AD Group step, it fails with the error below.
Execute_AddUserToADGroup Phase 1: An error occurred during ExecuteADPowerShell Powershell | Exception message 1: There was an error executing the script. Unable to contact the server. This may be because this server does not exist, it is currently down, or it does not have the Active Directory Web Services running.Exception message 2: There was an error executing the script. Unable to contact the server. This may be because this server does not exist, it is currently down, or it does not have the Active Directory Web Services running.Exception message 3: There was an error executing the script. Unable to contact the server. This may be because this server does not exist, it is currently down, or it does not have the Active Directory Web Services running. | Parameters: [DistinguishedName, CN= Licensing-Exchange,OU=Azure,OU=Security Groups - NEW,OU=Administration,DC=server1,DC=net] [UPNSuffix, user1@mycompany.net] [ProcessResult] (1x)
Cause
In one scenario, this was caused by the firewall blocking the powershell to run against a domain controller from the Bridgehead server. Powershell is using AD Web Services through port 9389.
Solution
The customer will need to investigate why and where the block is within the internal network. A quick way to test is by logging onto the bridgehead server and running the command: Get-ADGroupMember -identity $DistinguishedName (the distinguished name is in the error)
If it times out, the issue has been replicated.
Once the problem is resolved, restart the step and confirm.