ISSUE: Store message size limit step fails with error 'Microsoft.Exchange.Configuration.Tasks.ManagementObjectNotFoundException'
Last modified:
The Store message size limit step fails with the error below:
Ex6F9304|Microsoft.Exchange.Configuration.Tasks.ManagementObjectNotFoundException|The operation couldn't be performed because object 'test@yourdomain.com' couldn't be found on 'YY1PR06A08DC002.YYYPR06A008.PROD.OUTLOOK.COM'. [ProcessResult]
Additional details from the exchange logs:
get-mailbox -Identity “test@yourdomain.com” | Select PrimarySmtpAddress,Name,Database,Servername,Mailboxplan,OriginatingServer
PrimarySmtpAddress : test@yourdomain.com
Name : 908884
Database : DG004-db101
ServerName : exch01234
MailboxPlan : ExchangeOnlineEnterprise-a9e5ca2f-2edb-43c8-xxxx-1ca6f18fb4a6
OriginatingServer : YY1PR06A08DC002.YYYPR06A008.PROD.OUTLOOK.COM'
Cause
This was due to missing Exchange admin permissions
Solution
Verify the following permissions have been applied to the Exchange on-prem and O365 admin users:
Exchange On-Prem Admin Account
Roles required: (View-only Organization Management and Recipient Management)
O365 Cloud Only Admin account
Roles required: User Admin, Exchange Admin.
Once this has been corrected, restart the step.