ISSUE: Move Mailbox step fails with error 'Request_ResourceNotFound'

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Overview

The error below occurs on a Mailbox Move step:

Request_ResourceNotFound: Resource 'user1@mydomain.com' does not exist or one of its queried reference-property objects are not present. [ProcessResult]


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Cause

This occurs when there are two mailbox entries in the backend database and the address in the error is mapped incorrectly. 

Solution

To get around this issue, perform the following steps against the database. 

1. Running this query should return two rows: 

select * from mailboxes where UserPrincipalName = 'user1@mydomain.com'  <<enter the email address from the error


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2. The second row is the one that has to be updated.  The queries below have been populated to correct this. Run them both at the same time after modifying the values.  

update MailArchiveMappingsSelection set ExcMailboxId=13661 where ExcMailboxId=11892

update MailArchiveMigrationMappings set ExchangeMailboxId=13661 where ExchangeMailboxId=11892

3. Go back to the failed mapping in the admin portal and refresh the user. It should now reflect the correct address. If so, restart the step. 


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