ISSUE: MAPI_E_NOT_ENOUGH_MEMORY

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Overview

During accessing and migration of PST file we can experience following error:

Error in IMAPITable.SetColumns: MAPI_E_NOT_ENOUGH_MEMORY

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Cause

when you open a PST file in Outlook, Outlook will allocate a certain part of memory to it as a cache to improve the performance. In other words, Outlook has a limit in the amount of space available for each email accounts. When the space has run out, the Outlook error “Out of memory or system resources” will turn up which is same as MAPI_E_NOT_ENOUGH_MEMORY.

Solution 

Here are protentional solution that can resolve the issue:

1. Reduce the Number of PST Files Opened in Outlook - Having too many pst files open in outlook can cause performance as well memory issues

2. Reduce the Memory Cache Size for Each PST File - you can reduce the memory cache size which Outlook assigns to each PST files.

Here are the steps to perform:

  1. For a start, close Outlook and head to “Start Menu”.
  2. Then type “regedit” in search box and press “Enter” key button.
  3. In the Registry Editor, browse to the keys below: “HKEY_CURRENT_USER” > “Software” > “Microsoft” > “Office” > “<version>” > “Outlook” > “PST”.
  4. Next right click on “PST” key and choose “New” > “DWORD Value”.Create a New DWORD Value under PST
  5. Name the newly created value as “UseLegacyCacheSize”.
  6. Later specify its value data as “1”.
  7. Speicify Value Data of UseLegacyCacheSize
  8. Ultimately close Registry Editor and restart Outlook.

3. Repair the PST files - ScanPST.exe can repair any corruption/issues within the PST file that could potentially cause the Memory issue



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