ISSUE: 'Cannot insert duplicate key row in object 'dbo.Mailboxes'
Last modified:
Overview
The exchange module log shows a repeating error which may cause the module to show offline in the portal despite the service running:
WebRequest (PUT) to http://server01.corp.mydomain.com:8080/api/v1/Exchange/Mailboxes failed
EXCEPTION: [500|https://tools.ietf.org/html/rfc9110#section-15.6.1|An error occurred while processing your request.|Cannot insert duplicate key row in object 'dbo.Mailboxes' with unique index 'IX_Mailboxes_TenantId_UserPrincipalName'. The duplicate key value is (45, user1@mydomain.com).||00-169c110bac0e95bf38a2ff5188c7dca8-d7be44ef2d66506a-00|]
2024-04-30T14:32:12|ERROR|mydomain|10.62.50.75 |T:51 |TransmissionWorkerThread | || || ||Error in TransmissionWorkerThread
Cause
A bit of investigation found the user has two different accounts and the mailbox guid seems to have changed.
Solution
Currently, the fix is to contact engineering to correct this on a case by case basis.