ISSUE: Office 365 mailbox in different data center

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Overview

When accessing the O365 mailbox by powersehll or EWS commands you may receive following error:

The   specified object was not found in the store., Can't connect to the mailbox of   user Mailbox database guid: xxxxx-xxxx-xxxx-xxxx-xxxxxxxx because the   ExchangePrincipal object contains outdated information. The mailbox may have   been moved recently. 

Cause

This issue occurs because the mailbox is most likely hosted in different region from admin account region used for migration and the cmdlet doesn't work for a mailbox that's in a different region from the administrator's region.

Solution

  1. Connect to Exchange Online via PowerShell
  2. Run these two commands via PowerShell:

Get-Mailbox -Identity 'Mailbox with issue' | Select-Object WindowsEmailAddress,RecipientType,Database,MailboxLocations,ISshared,RoomMailboxAccountEnabled

Get-Mailbox -Identity 'Valid Mailbox' | Select-Object WindowsEmailAddress,RecipientType,Database,MailboxLocations,ISshared,RoomMailboxAccountEnabled

Compare the two results and pay attention to the Database output. 

Mailbox with the issue may be on different region datacenter then the O365 admin account.

You can try following for the mailbox with that error:

New-MoveRequest -Identity 'My Mailbox'

To check the status of the move, run:

Get-MoveRequestStatistics -Identity 'My Mailbox' | Format-List


Useful MS articles:

Cannot connect to the mailbox error when searching mailbox - Exchange | Microsoft Learn

Could not find database error when running cmdlets for different region mailbox - Exchange | Microsoft Learn


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