ISSUE: You can't use the domain because it's not an accepted domain for your organization
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Overview
During Move mailbox step you may receive following error:
"Execute_HYBRID_MoveMailboxToO365: An error occurred during Exchange Online Powershell | Ex04C125|Microsoft.Exchange.Configuration.Tasks.ManagementObjectNotFoundException|The operation couldn't be performed because 'L.Lawson@whiddon.com.au' couldn't be found. Reason: | Result: Not received [ProcessResult]"
Cause
The mailbox is configured with one or more email address with a domain that’s not accepted by Microsoft. If you don’t add and verify the domain in Office 365, you are not prohibited from using that domain.
Solution
1. Check the Accepted domain in O365
You can also connect to O365 via PowerShell and get the list:
"Get-AcceptedDomain"
2. Connect to Exchange Onprem and check the SMTP domains assigned to affected user:
"Get-mailbox UserUPN | select -ExpandProperty Emailaddresses"
3. If user have some SMTP domains that don't match accepted domains in O365 you need to remove them from user or add those domain to O365 so they are accepted.
If the mailbox got an internal hostname address as domain, Microsoft recommending to remove that address . An example of an internal address is .local, .priv, or .intra.
4. Once SMTP domain removed or added, run synchronization with Azure AD to replicate the on-premises AD changes to Azure AD
5. Restart the failed "Move Mailbox" step in the EVComplete UI