ISSUE: The operation couldn't be performed because 'Soft Deleted Object' matches multiple entries

Last modified:


Overview

During Move mailbox step you may receive following error:

Execute_HYBRID_MoveMailboxToO365: An error occurred during Exchange Online Powershell | Ex9E65A2|Microsoft.Exchange.Configuration.Tasks.ManagementObjectAmbiguousException|The operation couldn't be performed because 'Soft Deleted Objects\Sevilla+3caa7868-0b30-4eda-8757-e2971bacf39b' matches multiple entries. | Result: Not received [ProcessResult]

Image 366

Cause

The remote move migration fails because a soft-deleted or inactive mailbox has the same email address or UPN as the mailbox that's identified in the error message.

Solution

1. Check for the mailbox that's identified in the error message via powershell:
"Get-Mailbox -Identity <conflicting email address> | fl Name, Alias, DistinguishedName, GUID"


above command doesn't return soft-deleted or inactive mailboxes. To see all mailboxes (also deleted or inactive ) you need to run:

"Get-recipient -identity <conflicting email address>"


2. Permanently delete duplicated soft-deleted or inactive mailbox.

3. Rerun the failed step for the user from EVComplete UI

NOTE: if the soft deleted or Inactive duplicate mailbox cannot be deleted you need to manually migrate affected user from the Microsoft O365 portal.


Is this article helpful for you?