Issue: 'Message Conversion Error' during Mail Archive migration synchronization
Last modified:
Overview
The error below occurs during the Mail Archive migration synchronization workflow.
2023-01-04T13:14:46|ERROR|192.168.21.254|T:107|MessageConverter |user1@abc.com ||2 |1ec2516c-a800-46c7-8b3a-f8221a4def7c|7 ||Message Conversion Error
EXCEPTION: System.IO.FileNotFoundException: The system cannot find the file specified. (Exception from HRESULT: 0x80070002)
at Redemption.RedemptionLoader.IClassFactory.CreateInstance(Object pUnkOuter, Guid& refiid, Object& ppunk)
at Redemption.RedemptionLoader.NewRedemptionObject(Guid guid)
at Redemption.RedemptionLoader.new_RDOSession()
at System.Collections.Concurrent.ConcurrentDictionary`2.GetOrAdd(TKey key, Func`2 valueFactory)
at cloudficient.Common.Mail.FormatConversion.MessageConverter.GetThreadSession()
at cloudficient.Common.Mail.FormatConversion.MessageConverter.<>c__DisplayClass32_0.<ConvertToStream>b__0()
at cloudficient.Common.Mail.FormatConversion.MessageConverter.LogErrors[T](Func`1 action)
2023-01-04T13:14:46|ERROR|192.168.21.254|T:107|BatchWorkerThread |user1@abc.com ||2 |1ec2516c-a800-46c7-8b3a-f8221a4def7c|7 ||FTS Conversion error
EXCEPTION: System.IO.FileNotFoundException: The system cannot find the file specified. (Exception from HRESULT: 0x80070002)
at Redemption.RedemptionLoader.IClassFactory.CreateInstance(Object pUnkOuter, Guid& refiid, Object& ppunk)
at Redemption.RedemptionLoader.NewRedemptionObject(Guid guid)
at Redemption.RedemptionLoader.new_RDOSession()
at System.Collections.Concurrent.ConcurrentDictionary`2.GetOrAdd(TKey key, Func`2 valueFactory)
at cloudficient.Common.Mail.FormatConversion.MessageConverter.GetThreadSession()
at cloudficient.Common.Mail.FormatConversion.MessageConverter.<>c__DisplayClass32_0.<ConvertToStream>b__0()
at cloudficient.Common.Mail.FormatConversion.MessageConverter.LogErrors[T](Func`1 action)
at cloudficient.EVComplete.Module.Exchange.IngestionWorkers.BatchWorkerThread.PrepareBatch(List`1 batch, Int32 mappingId) in E:\_w\o\1\3\s\EV2O365.OnPrem.Exchange\IngestionWorkers\BatchWorkerThread.cs:line 186
Cause
This error will occur when Outlook has not been installed on the Bridgehead server.
Solution
Install the 64-bit version of Outlook on the Bridgehead server. Outlook 2013 and above are supported.
Once installed, launch Outlook so it can initialize and then close it down. There is no need to create a profile.
The error below occurs during the Mail Archive migration synchronization workflow.
2023-01-04T13:14:46|ERROR|192.168.21.254|T:107|MessageConverter |user1@abc.com ||2 |1ec2516c-a800-46c7-8b3a-f8221a4def7c|7 ||Message Conversion Error
EXCEPTION: System.IO.FileNotFoundException: The system cannot find the file specified. (Exception from HRESULT: 0x80070002)
at Redemption.RedemptionLoader.IClassFactory.CreateInstance(Object pUnkOuter, Guid& refiid, Object& ppunk)
at Redemption.RedemptionLoader.NewRedemptionObject(Guid guid)
at Redemption.RedemptionLoader.new_RDOSession()
at System.Collections.Concurrent.ConcurrentDictionary`2.GetOrAdd(TKey key, Func`2 valueFactory)
at cloudficient.Common.Mail.FormatConversion.MessageConverter.GetThreadSession()
at cloudficient.Common.Mail.FormatConversion.MessageConverter.<>c__DisplayClass32_0.<ConvertToStream>b__0()
at cloudficient.Common.Mail.FormatConversion.MessageConverter.LogErrors[T](Func`1 action)
2023-01-04T13:14:46|ERROR|192.168.21.254|T:107|BatchWorkerThread |user1@abc.com ||2 |1ec2516c-a800-46c7-8b3a-f8221a4def7c|7 ||FTS Conversion error
EXCEPTION: System.IO.FileNotFoundException: The system cannot find the file specified. (Exception from HRESULT: 0x80070002)
at Redemption.RedemptionLoader.IClassFactory.CreateInstance(Object pUnkOuter, Guid& refiid, Object& ppunk)
at Redemption.RedemptionLoader.NewRedemptionObject(Guid guid)
at Redemption.RedemptionLoader.new_RDOSession()
at System.Collections.Concurrent.ConcurrentDictionary`2.GetOrAdd(TKey key, Func`2 valueFactory)
at cloudficient.Common.Mail.FormatConversion.MessageConverter.GetThreadSession()
at cloudficient.Common.Mail.FormatConversion.MessageConverter.<>c__DisplayClass32_0.<ConvertToStream>b__0()
at cloudficient.Common.Mail.FormatConversion.MessageConverter.LogErrors[T](Func`1 action)
at cloudficient.EVComplete.Module.Exchange.IngestionWorkers.BatchWorkerThread.PrepareBatch(List`1 batch, Int32 mappingId) in E:\_w\o\1\3\s\EV2O365.OnPrem.Exchange\IngestionWorkers\BatchWorkerThread.cs:line 186
Cause
This error will occur when Outlook has not been installed on the Bridgehead server.
Solution
Install the 64-bit version of Outlook on the Bridgehead server. Outlook 2013 and above are supported.
Once installed, launch Outlook so it can initialize and then close it down. There is no need to create a profile.