ISSUE: "Item not found" error on extraction
Last modified:
Overview
Export of some items from Enterprise Vault may fail with error message "Item not found", logged in EVComplete EV log file.
2023-02-08T10:45:00|ERROR|192.168.21.254|T:150|MailArchiveExtractionWorker |1CF59097CC3AD4543B4C0E978140668E91110000vault ||2912 |579056b2-689c-44d9-9a4c-adca3ff47945| ||System.Runtime.InteropServices.COMException: Item not found.
EXCEPTION: System.Runtime.InteropServices.COMException (0x80040307): Item not found.
at KVS.EnterpriseVault.Interop.IItem.Get(Int32 DetailLevel)
at cloudficient.Common.EnterpriseVault.MailArchive.ExtractEVItem(IContentManagementAPI evAPI, String archiveId, Guid idTransaction, String contentSectionId, Boolean useTemporaryFile)
at cloudficient.Common.EnterpriseVault.MailArchive.ExtractEVItem(IContentManagementAPI evAPI, String archiveId, Guid idTransaction, String contentSectionId)
at cloudficient.Common.EnterpriseVault.MailArchive.ExtractEVItemInternal(IContentManagementAPI evAPI, String archiveId, Guid idTransaction)
at cloudficient.Common.EnterpriseVault.MailArchive.ExtractEVItem(String evHost, String archiveId, Guid idTransaction)
at cloudficient.EVComplete.Module.EnterpriseVault.ExtractionWorkers.MailArchiveExtractionWorker.ProcessItemExtract(Guid itm, ConcurrentBag`1 aborted, Guid state, StagingArea stagingArea) in E:\_w\o\1\11\s\cloudficient.EVComplete.Module.EnterpriseVault\ExtractionWorkers\MailArchiveExtractionWorker.cs:line 314
Cause
EVComplete module is getting this log entry from Enterprise Vault via EV API. It indicates that the item is no longer available as has been removed by EV or a user (even though the database entries for the item still exist).