ISSUE: Mailbox Move error 'MaxItemsInObjectGraph'

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Overview

During a mailbox move, it will stop processing with an error in the portal that shows below:

95 % complete. Status is Failed and Status Detail is FailedOther (BadItemsEncountered: 160). Failure message is CommunicationErrorPermanentException

This error is related to a different issue where the bad item count has been exceeded and the customer needs to resolve this.  The following article explains this in detail. 

https://support.cloudficient.com/knowledge-bases/2/articles/79-how-to-deal-with-baditemlimits

However, after resolving that error, the move continued to stay in the same failed state.  Upon reviewing the exchange backend logs, the error below was found:

Execute_HYBRID_MoveMailboxToO365 |user2@yourdomain.com ||724 |9016bbc7-4549-483d-beb2-5c3e850f7ab4| ||Move mbx statistics for user2@yourdomain.com: Percent complete [95] | Status [Failed] | Status detail [FailedOther] | Message [Error: The call to 'https://1967c6fa-b8fc-4dc2-96c4-0ed4cce3b411.resource.mailboxmigration.his.msappproxy.net/EWS/mrsproxy.svc mbx02.yourdomain.com (1.1.2507.32 ServerCaps:, ProxyCaps:, MailboxCaps:, legacyCaps:0FFD6FFFBF5FFFFFCB07FFFF)' failed. Error details: The formatter threw an exception while trying to deserialize the message: There was an error while trying to deserialize parameter http://tempuri.org/:ISourceFolder_EnumerateChanges2Result. The InnerException message was 'Maximum number of items that can be serialized or deserialized in an object graph is '2000000'. Change the object graph or increase the MaxItemsInObjectGraph quota.

Cause

This is due to the object graph limit configured in Exchange. 

Solution

The following article contains the fix for this issue. https://exchangetimes.net/?p=483

It will require the user to be unmapped and remapped once the customer has deleted the mailbox move request as per the steps in the article above.  


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