ISSUE: Specified folder not found for Revert Pending Shortcuts
Last modified:
Overview
During the execution of the "Revert Pending Shortcuts" workflow step, you may get following error:
2023-10-10T06:47:33|ERROR|WADOHSS |192.168.140.254|T:2588|Execute_EVRevertPendingShortcuts | ||3288 |50a5c9bb-be77-4c6c-8acc-98c6d1850f04| ||An error occurred during Revert EV Shortcuts for Criona.Smith@health.wa.gov.au/3288
EXCEPTION: cloudficient.Common.Mail.EWS.ManagedApi.ServiceResponseException: The specified folder could not be found in the store.
at cloudficient.Common.Mail.EWS.ManagedApi.ServiceResponse.InternalThrowIfNecessary()
at cloudficient.Common.Mail.EWS.ManagedApi.MultiResponseServiceRequest`1.Execute()
at cloudficient.Common.Mail.EWS.ManagedApi.ExchangeService.FindFolders(FolderId parentFolderId, FolderView view)
at cloudficient.Common.Mail.EWS.Folder.<>c__DisplayClass52_1.b__0()
Cause
Revert Pending Shortcut step is configured to perform also on the Online Archive mailbox but the mailbox is not enabled for user.
Solution
As there is no Online Archive enable for user, you can skip the step.