ISSUE: Error while attempting to Redirect Items to Archive

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Overview

When attempting to use the option called "Redirect to Items Archive", the error below will present itself in the exchange logs. 

|ERROR|customer1 |::ffff:10.41.1.54|T:66 |MailArchiveItemReRouteToArchive | ||8907 || ||Get API Call finished with error: /api/v1/MailArchiveItems/RedirectNotIngestedItemsToArchive
EXCEPTION: System.Net.Http.HttpRequestException: Response status code does not indicate success: 500 (Internal Server Error).


Cause

In this specific scenario, the mapping was in an error state.  Selecting the option "Redirect to Items Archive", then subsequently selecting the option "Reset Mailbox Level Error" caused a deadlock, hence the error above.  

Solution

To mitigate this, when the mapping is in an error state, first select "Redirect to Items Archive", then wait approx 30-45 seconds, then select "Reset Mailbox Level Error".  Note that you may need to do this sequence of events more than once but eventually it will begin to work.  


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