ISSUE: Send Email Step fails with error 'Object reference not set to an instance of an object'

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Overview

The Send Email step fails with the error below in the admin portal. 

Object reference not set to an instance of an object.

Upon further investigation, the backend_eventworker log shows the following:

Error during Start method for step SendEmailToUser.
EXCEPTION: System.NullReferenceException: Object reference not set to an instance of an object.

|ERROR|company|::ffff:10.31.1.27|T:126|StepBase | ||3 || ||Error during Start method for step SendEmailToUser. Details: Could not resolve default CAS Server for user@intra.company.org

Cause

This occurs when the Default CAS Server field is not populated in the portal.

Solution

In the portal, edit the properties of the Exchange Endpoint and select the proper Default CAS server. 

Image 377

Save the change and restart the step.  


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