ISSUE: The target mailbox doesn't have an SMTP proxy matching

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When migrating mailbox from Exchange on-prem to Exchange Online in O365 we can get following error on Move Mailbox workflow step:

Execute_HYBRID_MoveMailboxToO365: An error occurred during Exchange Online Powershell | The running command stopped because the preference variable "ErrorActionPreference" or common parameter is set to Stop: The target mailbox doesn't have an SMTP proxy matching 'domain.mail.onmicrosoft.com'. | Result: Not received [ProcessResult]


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Cause

This issue may occur if one of the following conditions is true:

  • The source mailbox isn’t stamped to have a <domain>.mail.onmicrosoft.com SMTP address.
  • The proxy address <domain>.mail.onmicrosoft.com is not synced to Office 365 on the corresponding cloud mail-user object.

Solution

Please follow this Microsoft article to add proxy domain to affected mailbox:
https://docs.microsoft.com/en-us/exchange/troubleshoot/move-or-migrate-mailboxes/no-smtp-proxy-matching


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