ISSUE: Target user already has a primary mailbox

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The Move Mailbox workflow step fails with the error below:

Target user already has a primary mailbox

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Cause

This error can occur by any of the following:

  1. The mailbox has been already migrated to O365 by the customer
  2. The mailbox has been migrated by EVComplete but the database record has not been updated yet
  3. There is more than one mapping for the user and the second mapping fails with this error due to the mailbox move being completed by the first mapping. 
Solution
  1. Connect to Exchange online and validate the mailbox exists
  2. Log into the database and run the following command that will update the mailbox move status. Then skip the step so it can proceed. 

update Mailboxes set IsO365Mailbox=1 where id in (select ExchangeMailboxId from MailArchiveMigrationMappings where MigrationProcessId in (select MigrationProcessId from ProcessSteps where StepErrorText Like 'Target user already has a primary mailbox%'))


      3. Skip the "Move Mailbox" step with that error.


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